Netflix Error M7121-3078

If you get the error code M7121-3078 on your computer, usually with this message:

Pardon the interruption
Looks like this version of your browser is no longer supported. Please install the latest version to continue watching.

It means that the version of Google Chrome you're using on your computer is no longer supported. Follow the steps below to fix the problem.

Steps for Mac

If your computer is on Mac OSX 10.11 (El Capitan) or higher:

Update Google Chrome
  1. In the upper right corner of your browser, select Menu .

  2. Select Help.

  3. Select About Google Chrome.

  4. Chrome will show the current version and automatically install any updates.

  5. Select Relaunch.

  6. Try Netflix again.


If your computer is on Mac OSX 10.10 (Yosemite) or earlier:

Your computer can't update to the latest browser versions needed to play Netflix. To keep watching Netflix, you'll need to use a different device.

Visit devices.netflix.com to see a list of supported devices.

Steps for Windows

If your computer is using Windows 7, Windows 8, Windows 10, or Windows 11:

Update Google Chrome
  1. In the upper right corner of your browser, select Menu .

  2. Select Help.

  3. Select About Google Chrome.

  4. Chrome will show the current version and automatically install any updates.

  5. Select Relaunch.

  6. Try Netflix again.


If your computer is using Windows Vista or Windows XP:

Your computer can't update to the latest browser versions needed to play Netflix. To keep watching Netflix, you'll need to use a different device.

Visit devices.netflix.com to see a list of supported devices.