Netflix says 'Please update your device. This version is no longer supported by Netflix. 5072'

If you see an error on your Apple TV, iPhone, iPad, or iPod touch that says:

Please update your device. This version is no longer supported by Netflix. 5072

It means your device needs an update from Apple. Follow the steps below to fix the problem.

Apple TV

Update your Apple TV

  1. From the Apple TV main menu, select Settings.

  2. Select General.

  3. Select Software Updates.

  4. Select Update Software/Update automatically.

  5. Select Download and Install.

  6. Once the update is complete, try Netflix again.​

Note:
If your Apple TV displays the message Your Apple TV is up to date and you are on a version lower than 6.2.1, we recommend contacting Apple or visiting Apple's support site for assistance. To check your firmware version, follow the steps below.
  1. From the Apple TV main menu, select Settings.

  2. Select General.

  3. Select About.

  4. Verify that your software version is 6.2.1 or above.

Update the Netflix app

  1. From the Apple TV home screen, select the App Store.

  2. From the menu at the top of the screen select Purchased.

  3. Select Netflix.

  4. If an update is available select Update.

    • If no update is available, continue troubleshooting below.

  5. Try Netflix again.

iPhone, iPad, or iPod Touch

Check for iOS version updates

Make sure your iPad, iPhone, or iPod touch has the latest version of iOS.

Update the Netflix app

  1. From the Home screen, tap the App Store icon.

  2. Tap Search, then enter "Netflix" in the search box.

  3. Tap Netflix, then tap Update.

    • If asked, enter your Apple ID password.

  4. Once the update is complete, try Netflix again.